Ending Support for Old Versions of Internet Explorer

As we continue to push out beautiful new releases to our flagship software, we are announcing that we are matching Microsoft’s and Google’s policies and ending support for old versions of Internet Explorer.

We continue to utilize new technologies that were not around a decade ago when IE 7 and IE 8 were released and thus cannot continue to support those versions while still providing you with the best possible experience in our system. While IE9 is slightly newer, it is still three major releases behind the current IE11 and lacks in many ways.

Thus, going forward we will only support IE11 and IE10 not running in compatibility mode, because it is time for out with the old.

Any questions? ask your friendly service specialist, or tweet me @born2code

Leave a Reply

Your email address will not be published. Required fields are marked *